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1.1 Software Overview

Psychology Software Tools’ SimFx software creates an auditory simulation of an authentic MRI 
environment. SimFx not only replicates the active scanner noises and generates ambient sounds, 
it also has the ability to play up to four different sound files simultaneously. It also is capable of 
accepting serial input to control sound playback from an external client. Coupled with a simulator, 
SimFx allows you to recreate an effective, simulated MRI environment.

The following pages guide you through the use and installation of SimFx. 

Chapter 1: Introduction
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1) Insert the SimFx installation
CD into your CD-ROM drive. 
Click “Next” when you see the

 window. 

2) Please read the License
 Agreement and make sure that
 you agree completely with the
 terms and conditions described
 in the agreement before
 proceeding. Once you have
 read the agreement, click

Next to proceed with the
 installation.

3)   Specify Your Name and 
Your Institution or check with 

      your system administrator for
      appropriate information. 

4)   The Serial Number field must
      be complete to obtain access
      to online Product Service and
     Support. 

5) Click Next to begin the
 installation.

 1

Chapter 1: Introduction
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1.2 Software Installation

Before continuing, be sure that you have administrative rights to install this software on the 
computer. If you do not have administrative rights, you will be unable to install SimFx. If you
are unsure of your administrative privileges, contact your System Administrator. 

NOTE: The version number on the following screen grabs may not correspond to the version 
number on your software.



9

SimFx Auditory Simulation Software User Manual - PST-100800 - Rev 5

6)  Click Install to begin the
 installation.

7)  Wait for the installation to
 complete.

8)  If SimFx was installed properly,
     you will see the following
     window. Click “Finish” to
     complete the installation.

 6

 7

Chapter 1: Introduction

 8
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1.2 Software Installation (continued)
Finding the “Documents” Folder
SimFx is compatible with Microsoft Windows XP, Vista, Windows 7 and Windows 8. When using 
SimFx, you will frequently be working within the “Documents” folder, because you will be able to 
save configurations and add new sounds to this folder without Administrative permissions. 

The table below shows the default paths to your personal documents folder. Note that the path on 
your particular machine may have been modified by your administrator:

Chapter 1: Introduction

Operating 
System Path to your personal documents folder(“My Documents” or “Documents”)

XP <drive>\Documents and Settings\<user name>\My Documents\
Vista <drive>\Users\<user name>\Documents\
Windows 7 or 8 <drive>\Users\<user name>\My Documents

When the SimFx documentation directs you to the “Documents” folder, it does not include the full 
path to the folder. Instead, the documentation refers to “…Documents”, where the “…” indicates the 
full path up to your personal documents folder. When you see this notation in the documentation, 
replace the “…” with the path to your personal documents folder.

Play a sound to test the installation is working
1)   After you have installed the SimFx software, open the application via the start menu or by  
 searching for SimFx in the Start screen.
2)   Once the application opens, click the browse button next to the Ambient Sound.
3)   Select a sound from the list to load and click open.
4)   Confirm the check box next to Ambient Sound is checked.
5)   Click the Play button to play the loaded sound. You will need to plug in speakers or
 headphones to hear the sound.
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2.1 Opening the Application

Once you have successfully installed the SimFx software you can open the application through 
either the Windows Start Menu, or typing SimFx in the start screen.

1) Click on the Windows Start
 menu, select All Programs, and
 then select SimFx. 

2) Click on SimFx to launch the
 application.

3) Wait for the application to load.
  

 1

 

2

 3

Chapter 2: Getting Started Guide
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Chapter 3: User Interface

3.1 Sound Playback

The SimFx software was designed to be user friendly with an intuitive interface. The sound 
library includes pre-recorded ambient noises and anatomical and functional scanner sounds. 
You can also add sound files to your sound library.

The only supported file format is .wav.

3.1.1 Supported file format

Background Sounds
File Name Scan Type/Description Length Sound Type

AmbientNoise.wav White noise, static 10 seconds monophonic
CryogenicPump.wav Noise from cryogenic pumps in scanner room 7.47 seconds monophonic
AmbientCryogenic.wav Ambient.wav and CryogenicPump.wav in one .wav file 7 Seconds monophonic

Scanner Sounds
File Name Scan Type/Description Length Sound Type

GE_DTI.wav Diffusion Tensor Imaging sequence 14.29 seconds monophonic
GE_SE.wav Spin Echo sequence 9.89 seconds monophonic
GE_EPI.wav Echo Planer Image sequence 4.89 seconds monophonic

GE_GRE.wav Gradient Echo sequence, 2D low resolution structural 
(InPlane) 4.77 seconds monophonic

GE_SPGR.wav Incoherent Gradient Echo (RF Spoiled), Spoiled GRASS 
sequence, 3-D high resolution structural sequence 7 minutes monophonic

Siemens_DTI.wav Diffusion Tensor Imaging sequence 16.80 seconds monophonic
Siemens_Echo.wav Fast Spin Echo sequence 10.35 seconds monophonic
Siemens_EPI.wav Echo Planer Image sequence 59.60 seconds monophonic
Siemens_Localizer.wav Low resolution structural image sequence 14.29 seconds monophonic

Siemens_MPRAGE.wav Gradient Echo 3D high resolution structural sequence 6 minutes 53 
seconds monophonic

Siemens_PD-T2.wav Proton density T2 weighted Image sequence, low 
resolution structurals (InPlane) 57.35 seconds monophonic

3.1.2 Sound library

NOTE: You need Administrative rights to add/change/remove any sound file from the default 
sound location.
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Chapter 3: User Interface

3.2 Load Sound

In order to load a sound file, click the browse buttons located on the right side of the application, 
navigate to the appropriate folder and select a sound file to play. The browse file window 
automatically opens at the designated location of the installed sound files. 

 2

 3

 

1

1) Click on the Browse button to
 select a file. 
 
 NOTE: You will be directed
 to the default Sound Folder
 location which is: C:\Program 
 Files(x86)\PST\SimFx\Sounds.
 or C:\Program Files\PST\SimFx\
 Sounds.

2) Select a file.

3)   Click Open.
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Chapter 3: User Interface

3.3 Play Sound File

The play and stop buttons are disabled until a sound file is loaded in one of the text boxes. The 
checkbox that corresponds with the loaded sound file must be checked for SimFx to play the file. 
The sound file playback is controlled by the play and stop buttons located at the bottom of the 
application.

4) Confirm the checkbox is
checked. The name of the

 loaded sound file appears
 in the digital display.

5) Click Play to begin playback.

6) Click Stop to terminate
 playback.
 NOTE: Once playback has
 begun, the loaded sound file
 cannot be changed before
 playback is terminated.

7) Check the equalizer.
  NOTE: If the equalizer is
 animated, but you cannot hear
 the sound, check that the system
 volume is not muted or turned
 down and check the speaker
 connections.

 7

 6 5

 4
 4
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Chapter 3: User Interface

3.4 Volume Control

The volume control for each sound file is located beneath the digital display. The slider is used to 
control the volume of the associated sound file. To decrease the volume, drag the slider to the left; 
to increase the volume, drag the slider to the right.

 1

 

2

1) Click and drag the slider left
 and right to increase or
 decrease the volume. 

2) The text below the slider
 indicates the volume level (%). 
 NOTE: The volume control for
  each sound file is located
 beneath the digital display. 
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4.1 Basic Features

The menu bar consists of two menus, File and Help. The File menu contains general application 
functionality such as the save, open, exit operations. The Help menu contains a link to the 
documentation and information about the SimFx program.

1) New: This menu option clears
 all user defined configurations,
 and returns the application state
 to the default.

2) Open: Allows a previously saved
 configuration to be loaded.

3) Save: Saves current user
 configuration into a .ses file. 
 If the configuration does not
 initially have a name, you will be
 prompted to name the file.
 The default save location is the
 ...Document folder.

4) Save As: Saves current user
 configuration into a file.
 The name of the .ses file and
 save location can be specified
 by the user.

 1

 4

 3

 2

Chapter 4: File Menu



17

SimFx Auditory Simulation Software User Manual - PST-100800 - Rev 5

Chapter 4: File Menu

4.1 Basic Features (continued)

SimFx installs several sample sound files in a default location on the installation system. The 
location is C:\Program Files(x86)\PST\SimFx\Sounds, or C:\Program Files\PST\SimFx\Sounds. 
This location can be accessed via the File Menu for convenience. The default sound folder can 
also be changed to any folder located on the system, e.g., “...Documents”  is a good place if you 
have limited permissions. Please note, you must have administrative privileges to write to the 
default sound folder location.

 2
 1

 3

1) Go to File Menu, Select Sound
 Folders.

2) Click User Defined Folder.

3) Browse to desired location you
 wish to save your sound files.

4)  Confirm the Default Folder
is set to the location of the sound

 files to be played.

5) Confirm the Default Folder.
NOTE: The location of the sound

 files can be reset at anytime by
 selecting the Default Folder
 option via the File Menu.

6) Click OK.

 6

 3

 

 

4

 5
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Chapter 4: File Menu

4.2 Serial Configuration

SimFx is able to communicate with other entities via serial connection. You need to determine 
which COM port is assigned to your serial port and assign that COM port number in the Serial 
Communications dialog. To open the Serial Communications options, simply check the check box 
in the upper right of the application labeled, “Serial Communications.” Basic information regarding 
serial ports settings can be found in Appendix A: COM Port Settings, (Page 23). If you have 
questions about your serial port configurations, please contact your network administrator or other 
computer support personnel.

 3

1) Check the checkbox next to Serial
 Communications to open the

Serial Communications option
 dialog.

2) Click the COM port dropdown
 menu to set the appropriate

COM port.
NOTE: If you have not

 determined what COM Port
 number is assigned to your
 serial port please contact your
 network administrator or other
 computer support personnel.
 See Appendix A, (Page 23).

3) Click OK to close the Serial
 Communications dialog. 

 2

 

1
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Chapter 4: File Menu

4.2 Serial Configuration (continued)

Once you have defined a COM port, SimFx will listen for commands via the serial port. The 
commands are single-line XML elements that use standard opening/closing tags. These tags 
instruct the SimFx application to perform an operation. The commands need to be called 
from within E-Prime 2.0 Professional via a task event or by calling an .xml file that has the 
corresponding commands saved in it. When using the XML commands in E-Prime, an additional 
End tag, <E>, is necessary. For more information, see our Knowledge Base article: KB 5614: INFO: 
SimFx Serial Communication Setup Details.

XML Tags
Open Tag Close Tag Description Values

<LdAmbient> </LdAmbient>
Loads sound file from current the Sounds folder to the Ambient Sound 
slot.  If you wish to load a file from another location you must change the 
default Sounds folder to that location.

String

<SetAmbient> </SetAmbient> A Boolean value that turns the Ambient Sound on and off. 
(on = True, off = False). True/False

<VolAmbient> </VolAmbient> A number that specifies the volume of the Ambient Sound in decibels (dB). 
100% is equal to 0 dB.

-10000 dB 
to 0 dB

<LdScanner> </LdScanner>

Loads sound file from the current Sounds folder to a Scanner Sound slot.  
You must specify which Scanner Sound slot using the <Count> tag.  If 
you wish to load a file from another location you must change the default 
Sounds folder to that location.

String

<SetScanner> </SetScanner> A Boolean value that turns the Scanner Sound on and off 
(on = True, off = False). True/False

<VolScanner>* </VolScanner> A number that specifies the volume of the Scanner Sound in decibels (dB).
100% is equal to 0 dB. 

-10000 dB 
to 0 dB

<Count>** </Count> A numeric value that determines which Scanner Sound is set. 1, 2, 3
-- <Play/> Plays whichever sounds are loaded in the application. N/A
-- <Pause/> Pauses whichever sounds are loaded in the application. N/A
-- <Stop/> Stops sound playback. N/A
-- <Exit/> A numeric value that determines which Scanner Sound is set. N/A

*All Load and Volume commands need to follow their respective Set commands. 
**The count command must follow SetScanner.

http://www.pstnet.com/internal/support/kb.asp?TopicID=5614
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Chapter 4: File Menu

4.2 Serial Configuration (continued)

Steps for controlling SimFx with E-Prime Professional
1) Go to the Task Events tab on the Object you want to have trigger the scanner sound. For this
 example, we use the offset time of the directions because that is when the scanner would
 start in an actual experiment. You may choose to already have the ambient and cryogenic
 sound running when you bring the participant into the room to train them.

2) First, in the Experiment Object Properties Duration/Input Tab, you must change the direction
 object’s Duration to (infinite), and set the PreRelease to 0. Then go to the Task Event Tab and
 click Add, and double click `Directions’.OffsetTime.

3) Choose Serial for the Task Device Name.

4) Select WriteString for the Action.

5) Set Source to (custom)

6) In Custom type:<SetScanner>True</SetScanner><LdScanner>GE_EPI.wav</
 LdScanner><Count>1</Count><VolScanner>0</VolScanner><E>

7) Set Data Type to String.

8) Then click OK.

9) Use the OnsetTime task event and the <Stop/> <E> tags to stop the scanner sounds on the
 “GoodBye” Object in the experiment.

 For more information, see KB 5614: INFO: SimFx Serial Communication Setup Details.

http://www.pstnet.com/internal/support/kb.asp?TopicID=5614
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Chapter 4: File Menu

4.3 Open Log File Location

SimFx produces a log file that can be used to verify the application is functioning appropriately. The 
log file is opened via the File Menu. This file contains information and operations performed by the 
SimFx application.

1) Open the File Menu, Select
Open Log File Location.

2) The SimFxLogFiles dialog
 lists the location and file
 names of the available SimFx
 Log Files.

 1

 

 

2
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Chapter 4: File Menu

4.3 Open Log File Location (continued)

This is an example of the SimFx log file. It is a tab-delimited file and can be opened in standard 
text editors, such as notepad.  The log reports the current Serial Communications settings, current 
sound folder location and a list of the operations performed by the SimFx application. 

1) Current Sound Folder Location  (sound file)

2) Serial communication settings (Initializing Serial Port ComPort = COM1)

3) List of Actions performed by application

4) What sound file is played (Audio File Location = EPISound4.wav)

 

4

 1

 

2

 

 

 

3
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Appendix A: COM Port Settings

COM Port: This option designates which port you want the program to use to communicate.
   Predefined values: COM1, COM2 (available COM port will populate list) 
   Default value: COM1 usually (you must determine which COM you need to use
   via device manager)

Baud Rate: This option controls the number of data bits per second that are transferred via the
   selected port.
   Predefined values: 9600,14400,19200,28800,38400,56000,128000,256000 
   Default value: 9600

Data Bit: This option changes the number of data bits you want to use for each character
   that is transmitted and received.
   Predefined values: 5,6,7,8
   Default value: 8

Parity: This controls the type of error checking the device performs. Please be advised that
   the computer or device you are communicating with must have the same setting as
   what you chose here.
   Predefined values: None, Odd, Even, Mark, Space
   Default value: None

Stop Bit: Changes the time between each character being transmitted.
   Predefined values: 1, 1.5, 2
   Default value: 1

 NOTE: For more information about configuration settings consult the help provided by your
   OS, or contact your computer support personnel.
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Appendix B: Contact Information

For additional information or support 

Contact us at
Psychology Software Tools, Inc

311 23rd Street Extension, Suite 200
Sharpsburg, PA 15215-2821

Phone: 412-449-0078
Fax: 412-449-0079
www.pstnet.com

For Product Service and Support:
Please visit us at https://support.pstnet.com
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