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To the Reader  

 

Welcome to g.tec’s world of medical and electrical engineering! 

Discover the only professional biomedical signal processing platform under MATLAB and 

Simulink. Your ingenuity finds the appropriate tools in the g.tec elements and systems. 

Choose and combine flexibly the elements for biosignal amplification, signal processing and 

stimulation to perform even real-time feedback. 

 

Our team is prepared to find the better solution for your needs. 

Take advantage of our experience! 

 

Dr. Christoph Guger Dr. Guenter Edlinger 

 

 

Researcher and Developer 
 

Reduce development time for sophisticated real-time applications from month to hours. 

Integrate g.tec's open platform seamlessly into your processing system. 

g.tec's rapid prototyping environment encourages your creativity. 

 

Scientist 
 

Open new research fields with amazing feedback experiments. 

Process your EEG/ECG/EMG/EOG data with g.tec's biosignal analyzing tools. 

Concentrate on your core problems when relying on g.tec's new software features like ICA, 

AAR or online Hjorth's source derivation. 

 

Study design and data analysis 
 

You are planning an experimental study in the field of brain or life sciences? We can offer 

consultation in experimental planning, hardware and software selection and can even do the 

measurements for you. If you have already collected EEG/ECG/EMG/EOG, g.tec can analyze 

the data starting from artifact control, do feature extraction and prepare the results ready for 

publication. 
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Preface 
 

This section includes the following topics: 

 

Required Products 

 

Using This Guide - Suggestions for reading the handbook 

 

Conventions - Text formats in the handbook 
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Required Products 

g®.HReeg uses: 

g®.BSanalyze - the advanced biosignal analysis software package from g.tec 

 

MATLAB - as basic matrix operation platform  

Signal Processing Toolbox - to give access to standard signal analysis tools 

Image Processing Toolbox - to generate scalp and brain boundaries from MRI/CT data 
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Using This Guide 

Chapter “Generate ERD Maps” explains how to generate an electrode montage file and how 

to calculate event-related desynchronization (ERD) maps. The ERD maps are imported into 

g.HReeg and are shown with MRI/CT scalp and brain images.  

Chapter “Generate Boundaries” shows the calculation of scalp and brain boundaries from 

MRI/CT data. 

 

Chapter “Electrodes” shows how to import and show electrodes together with MRI/CT data 

and how to fit the electrodes to the MRI/CT data. 

Chapter “Visualization” shows the 2D/3D visualization options for displaying the map-, 

scalp-, brain-data and electrodes. Furthermore, the manipulation of axis properties such as the 

rotation of the head is shown. 

Chapter “Data Interpolation and Laplace Derivation” shows how to interpolate electrode 

positions and how to calculate a spline surface Laplace derivation. 

Chapter “Help” explains the usage of the on-line help, the printable documentation and the 

function help. 
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Conventions 

 

Item Format Example 

MATLAB code  Courier to start simulink, type  
simulink 

String variables Courier italics set(P_C,'PropertyName',...) 

Menu items Boldface  Select Save from the File menu. 
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 Hardware and Software Requirements 
 

For Hardware and Software Requirements see the g.BSanalyze manual. 
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Generate ERD Maps 

 
The Chapter Generate ERD Maps explains the following topics: 

 

Create a Montage File 

Calculate a Spline Surface Laplace Derivation 

Calculate ERD 

Load ERD Data 

Add Scalp Data 

Add Brain Data 

Manipulate the Visualization 

Print Results 

Save Data and Exit 
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Create a Montage File 
 

The Montage Creator is used to define electrode names and positions. The x-, y- and z-

positions of the electrodes (e.g. measured by Polhemus Fastrak) can be loaded from files 

containing the coordinates in ASCII format (*.txt), boundary files (*.bnd) or can be entered 

manually. If the three dimensional coordinates are not available it is possible to estimate the 

coordinates from a planar electrode grid and using a spherical head model by performing the 

following steps: 

1. After starting MATLAB and setting the correct path, type:  

 
gbsanalyze  

 

in the MATLAB command line 

 

 
 

2. g.BSanalyze starts with a blank data window 

 

3. Open gMONcreator from the Run! Menu 
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4. gMONcreator opens with the following window: 
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Fit the Electrodes to a Spherical Head Model 

1. Click on Load Montage in the File menu and open 63ch_example.mat from 

 
Documents\gtec\gBSanalyze\testdata\montage 

 

The Montage Creator shows a 10/10 System electrode grid with 63 defined electrodes. 

The electrode grid contains normalized x- y- and z- coordinates of the electrodes.  

Select e.g. the Cz electrode. The field Position (X / Y / Z) displays the coordinates:  
0 / 0 / 1. 
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2. To fit the electrode coordinates onto a three dimensional spherical head model click on 

one of the defined electrodes and then press the Fit to sphere button 

 

 
 

A window opens asking for the scalp radius for estimation 

 

 
 

Enter 100 mm as the radius of the spherical head model and press OK. 

 

The Montage Creator estimates the coordinates. Select e.g. the Cz electrode which has 

now the Position (X / Y / Z): 0 / 0 / 100 mm. 

 

3. Select Save montage as... from the File menu and save the montage as 63ch_xyz.mat 

under 

 
Documents\gtec\gBSanalyze\testdata\montage 
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Load Electrode Positions 

 

1. Click on Load Montage in the File menu and open 60ch_square.mat from 

 
Documents\gtec\gBSanalyze\testdata\montage 

 

The Montage Creator shows a square electrode grid with 60 defined electrodes. The 

electrode grid contains only x- and y- coordinates of the electrodes.  

 

2. Select the electrode of the montage which corresponds to Cz in the international 10/20 

electrode system. 

 

3. Enter the name Cz into the Channel name editor box and press the Confirm button. 

 

4. Inspect the coordinates of the electrode in Position (X / Y / Z):, they are 0 / 0 / 0. 

 

5. Select the electrode that corresponds to Fz in the montage and assign the name Fz with 

the Confirm button. 

 

6. Import x-, y- and z-coordinates from a boundary electrode file by opening Import 

Positions from the File menu and selecting electrodes60.bnd from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Electrodes 
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7. Click e.g. on electrode Cz (electrode number 61) to inspect the coordinates again. They 

are now -0.66115 / -15.813 / 81.4715. 

 
 

8. Save the montage as electrodes60.mat under 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Electrodes 

 

9. Close the Montage Creator 
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Calculate a Spline Surface Laplace Derivation 

 

Global approaches of surface Laplacian are based on analytical functions that describe the 

potential distribution on the scalp. These analytical functions are referred to as splines. This 

name comes from the flexible reeds used by ship-wrights to constrain wooden planks in a boat 

construction.  

),,(),,( zyxUzyxV  , with iiii VzyxU ),,( .   (1) 

The potential distribution V is given by the spline U(x,y,z), and it should return the measured 

potential Vi at electrode i. Splines can be defined on either spherical or realistically shaped 

surfaces. The surface Laplacian is obtained by computing the second derivative with respect 

to the local head surface:  

2

2

2

2
2 ),,(),,(

v

zyxU

u

zyxU
Vis









 ,      (2) 

with u and v serving as the surface coordinates. Different implementations of the spline 

surface Laplacian, either for spherical of more realistic shaped surfaces, have been introduced 

(Perrin et al. 1989; Nunez and Pilgreen 1991; Law et al. 1993; Nunez et al. 1994; Babiloni et 

al. 1996; Babiloni et al. 1997).  

An advantage of the spline-based surface Laplacian methods is that the potential distribution 

can be approximated rather than interpolated. This becomes a substantial advantage whenever 

the potential distribution is contaminated by noise. The amount of approximation can be set 

by a regularization parameter.  

Perrin, F., Pernier, J., Bertrand, O., Echallier, J., 1989. Spherical splines for scalp potential and current density 

mapping. Electroencephalogr. Clin. Neurophysiol. 72, 184-187. 

Nunez, P., Pilgreen, K., 1991. The splineLaplacian in clinical neurophysiology: a method to improve eeg 

spatial resolution. J. Clin. Neurophysiol. 8 (4), 397-413. 

Law, S., Nunez, P., Wijesinghe, R., 1993. High resolution EEG using spline generated surface Laplacians on 

spherical and ellipsoidal surfaces. IEEE Trans. Biomed. Eng. 40 (2), 145-153. 
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Nunez, P., Silberstein, R., Cadusch, P., Wijesinghe, R., Westdorp, A., Srinivasan, R., 1994. A theoretical and 

experimental study of high resolution EEG based on surface Laplacians and cortical imaging. 

Electroencephalogr. Clin. Neurophysiol. 90, 40-57. 

Babiloni, F., Babiloni, C., Carducci, F., Fattorini, L., Onorati, P., Urbano, A., 1996. Spline Laplacian estimated 

of EEG potentials over a realistic magnetic resonanceconstructed scalp surface model. Electroencephalogr. 

Clin. Neurophysiol. 98, 363-373.  

Babiloni, F., Babiloni, C., Carducci, F., Gaudio, M.D., Onorati, P., Urbano, A., 1997. A high resolution EEG 

method based on the correction of the surface Laplacian estimate for the subject's variable scalp thickness. 

Electroencephalogr. Clin. Neurophysiol. 103, 486-492. 

 

Perform the following steps: 

1. Select Import BKR from the File menu of the Data Editor to load the file FOOT.bkr 

which is located in 

 
Documents\gtec\gBSanaylze\testdata\gHReeg\ 

 

 

The Data Editor shows a 60 channel EEG data-set consisting of 40 trials (epochs) with 2560 

samples each. The data was recorded with 256 Hz.  
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The subject performed a cue-paced foot movement imagination at second 3 of every trial. The 

end of imagination was indicated and the subject was instructed to perform the imagination 

until second 8 of each trial. The task was repeated 40 times. 

2. Select Spline Surface Laplace under the Pre-Processing menu to open the following 

window: 

 

The window has the following entries: 

Specify MONTAGE FILE: 

Name of file – select a montage file with x-, y- and z-coordinates of the electrodes 

 

Smoothing factor – enter a smoothing factor between 0 (no smoothing) and 1 (maximum 

smoothing) 

 

Define MONTAGE and GEOMETRY: 

g.MONcreator – open the Montage Creator to edit the montage file 

 

Geometry – open the Geometry window to inspect and edit the coordinates 

Result procedure – check the corresponding radio button to add the Spline Surface Laplace 

channels to the current data channels in the Data Editor or to replace all existing channels. 

The newly created channels get the attribute SSL. 
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3. Select e.g. the montage file 60ch_xyz.mat that was created in Section Create a 

Montage File and is stored under 

 
Documents\gtec\gBSanalyze\testdata\montage 

 

4. Enter as Smoothing factor 0.2. The Smoothing factor can be between 0 (no smoothing) 

and 1 (maximum) 

 

5. Select the radio button Replace all channels to view only the new calculated Spline 

Surface Laplace channels 

 

6. Press Start to perform the calculation 

The Data Editor is updated with the newly calculated channels. 
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Calculate ERD 
 

g.HReeg can show topographic maps of data that can be loaded into g.BSanalyze if they 

consist of only one trial (e.g. bandpower values, raw-data) and one of the following analyzes 

results: 

 

Average – average data over trials e.g. used for evoked potentials (EP’s) 

ERD – Event Related Desynchronization – calculate ERD in percentage, absolute power, 

absolute amplitude or z-values (see the g.BSanalyze documentation for details) 
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To calculate the event-related desynchronization (ERD) and event-related synchronization 

(ERS) for a 60 channels data-set follow these steps: 

1. Open the ERD – Event Related Desynchronization window from the Analyze menu in 

g.BSanalyze 

 

2. Enter 500 ms into the editor box Start of reference period at and 1500 ms into End of 

reference period at 
 

3. Select the MU-2 filter to calculate the ERD from 11-13 Hz 

 

4. Set the Factor for Horizontal averaging to 32  

 

5. Check the Save results box and enter as filename SSLerd.mat to save the calculated 

ERD results 

 

6. Press the Start button to perform the analysis. g.Result2D opens with the calculation 

results. 

 

7. Close the ERD – Event Related Desynchronization dialog. 

 

8. Click on Arrangement in g.Result2D to open the following window: 

 

9. Select the Grid Square (11 x 11) and check Zoom to page to show the channels in 

the topographically correct arrangement 
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The plot shows an ERD on the parietal area (around channel 49) and an ERS around C3 

(channel 28) and C4 (channel 34). 
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Load ERD Data 

 

 

To show the calculated ERD with the corresponding electrodes in g.HReeg follow these steps: 

 

1. Start gHReeg from the Run! menu of the Data Editor and click on Load under the 

Electrode menu. Select the montage file 60ch_xyz.mat under 

 
Documents\gtec\gBSanalyze\testdata\montage 

 

g.HReeg shows the created montage. 

 

 

 

2. Click the Load item from the Data menu and select the file SSLerd.mat from  

 
Documents\gtec\gBSanalyze\testdata\gHReeg\erd 
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g.HReeg shows in the status line the number of loaded Channels, the Type of signal – ERD 

and the data length – 10 seconds: 

 

 
 

Furthermore the 60 electrodes and the data map are shown: 
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3. Click on the Visualization menu and select Display Settings to open the following 

window 

 

 
 

4. Check the Invert colormap box in the Set MAP parameters field to show an amplitude 

attenuation (ERD) in red color and an amplitude enhancement (ERS) in blue color 

 

5. Enable the Confine to box and set the min color value to –120 and the max color value 

to 345 

 

6. Under the Select ARRANGEMENT and TIME frame area enter in Nr. rows 2 and in 

Nr. cols 4  

 

7. Set the Time steps from editor box to 2, the step size to 1 and the to editor box to 8 

seconds 

 

8. Press the Apply ! button  

 



User Manual g.HReeg 5.16.02  26 

g.HReeg shows the maps from second 2 until second 8 to investigate the ERD evolution over 

time.  
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Add Scalp Data 

 

 

1. To add scalp data to the ERD maps select Load from the Scalp menu 

 

2. Select the file subject1_scalp.bnd from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Boundary 
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Add Brain Data 

 

To add brain data to the ERD maps select Load from the Brain menu. Select the file 

subject1_brain.bnd from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Boundary 

 

1. Disable the Show Scalp entry under Visualization to show only the brain and the ERD 

maps. 
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Manipulate the Visualization 

 

1. Open the Axis Settings window under the Visualization menu and press the Top button 

to view the scalp from top 

 
 

2. Press Apply ! to rotate the maps and close the window with Cancel 

 

3. Check the Show Scalp item under Visualization 
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g.HReeg show the ERD maps and the scalp from top view. The ERD (red color) starts around 

second 3 on the parietal area. The ERS (blue color) can be found from second 5 to 7 around 

C3 and C4. 
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Print Results  

 

Select Print Preview in the File menu to open the following window: 

 

 
 

Press the Print button to start the printout of the data. 
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Save Data and Exit 

 

1. To save the g.HReeg data (map, scalp, brain and electrodes) chose Save as … under 

the File menu 

 

2. Enter the name Test.mat and save it to the directory 

 
Documents\gtec\gBSanaylze\testdata\gHReeg 

 

3. Select Exit under File to close g.HReeg 
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Generate Boundaries 

 

Chapter Generate Boundaries shows how to calculate scalp and brain boundaries of 

segmented MRI data files. 

 

Scalp Boundary 

Brain Boundary 
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Scalp Boundary 

 

Scalp and Brain Boundaries can be generated from *.mri segmentation files. 

 

 
 

The dialog box has the following entries: 

 

Select segmented MRI/CT – chose the segmented MRI/CT file with the Browse button 

 

MRI/CT dimension (status) – number of rows, columns and slices stored in the segmented 

MRI/CT file 

 

Voxel size [mm] (status) – dimension of each voxel in the segmentation file 

 

Reduce MRI/CT dimensions by – enter rows=1, columns=1 and slices=1 to take every 

voxel, enter rows=2, columns=2 and slices=2 to take every second voxel,… 

 

Generate head model – select the resolution of the scalp model (8 steps from lowest to 

finest) 

 

Iterations – enter the number of iterations for the calculation of the scalp model (range 0-

100). 

 

1. Click on Generate from MRI/CT under the Scalp menu and select the file 

subject1.mri from  

 
Documents\gtec\gBSanalyze\testdata\gHReeg\MRI 

 

The segmentation file contains an MRI image with 256 rows, 256 columns and 170 slices. 
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The Voxel size is 1 mm x 1mm x 1mm. 

 

2. Select very fine from the Generate head model pull down menu and enter 100 

under Iterations 

 

3. Press Start to generate the boundary file 

 

The g.HReeg window opens with the scalp boundary: 

 

 



User Manual g.HReeg 5.16.02  36 

 

4. Click on Axis Settings under the Visualization menu to open the following window: 

 

 
 

5. Check the Show axis box to indicate the range of the x-, y- and z-axis. Press Apply ! and 

close the window with Cancel. 

 

6. To reduce the number of triangles used for the scalp presentation open the Manage Scalp 

window from the Scalp menu 
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The window has the following entries: 

 

Reduce number of triangles to [%] – remove a certain percentage of triangles from the 

boundary 

 

Cut triangles – check the box to cut triangles above or below a certain plane 

 

Position [mm] – enter the coordinates of the plane which is normal to the specified  

direction vector 

 

Direction – enter the direction vector. Direction 1 means that the triangles below the plane 

are cut, Direction –1 means that triangles above the plane are cut. 

 

7. Check the Cut triangles box and enter a z-Position value of 30 mm. Set the z-Direction 

to -1. This cuts all triangles above 30 mm. 

 

8. Press Start to perform the operation 

 

 



User Manual g.HReeg 5.16.02  38 

 

9. Select Save as from the Scalp menu, enter the name scalp30mm.bnd and set the path 

to 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Boundary 
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Brain Boundary 

 

Brain Boundaries can be generated in the same way as Scalp boundaries: 

 

 

1. Click on Generate from MRI/CT under the Brain menu and select the file 

subject1.mri from  

 
Documents\gtec\gBSanalyze\testdata\gHReeg\MRI 

 

The segmentation file contains an MRI image with 256 rows, 256 columns and 170 

slices. The Voxel size is 1 mm x 1mm x 1mm. 

 

2. Select very fine from the Generate head model pull down menu and enter 100 

under Iterations 

 

 
 

3. Press Start ! to generate the boundary file 
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The g.HReeg window opens with the brain boundary: 

 

 

 

4. To remove the back side of the brain boundary open the Manage Brain window from 

the Brain menu 

 

5. Check the Cut triangles box and enter an x-Position value of 0 mm. Set the x-

Direction to 1. This cuts all triangles below 0 mm in x-direction (opens the back side 

of the brain). 
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6. Press Start ! to perform the operation 

 

7. Open Axis Settings from the Visualization menu, press on the Rear right button and 

press Apply ! 
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g.HReeg shows the brain from the back side: 
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Electrodes 
 

Chapter Electrodes shows how to load electrodes into g.HReeg and how to fit electrodes to 

the MRI/CT images. 

 

Load and Visualize Electrodes 

Fit Electrodes 
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Load and Visualize Electrodes 

 

1. Select Load under the Electrode menu and chose the file 60ch_xyz.mat from 

 
Documents\gtec\gBSanalyze\testdata\montage 

 

g.HReeg shows the electrode grid: 

 

 

2. From the Scalp menu open the scalp file subject1_scalp.bnd with Load from  

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Boundary 
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g.HReeg show the scalp with the 60 electrodes. The electrodes are not fitted to the MRI/CT 

image. 
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Fit Electrodes 
 

To fit the electrodes exactly to the MRI/CT image open Fit Electrodes under the Electrode 

menu. 

 

 
 

The Nasion coordinates in the electrode coordinate system and in the MRI/CT coordinate 

system must be known to perform the operation. The coordinates can either be entered 

directly if known (e.g. from the Montage Creator or from Polhemus data) or can be 

estimated/defined. 

 

The dialog window has the following entries: 

 

Define Nasion in electrode coordinates – enter the x-, y-, and z-coordinates of the Nasion in 

the electrode montage system in mm. The coordinates can be viewed e.g. in the Montage 

Creator.  

 

Estimate – press the button to estimate the Nasion position. This function works only if Cz 

and Fz are defined in the loaded electrode configuration file. 

 

Define Nasion in MRI/CT coordinates – enter the Nasion coordinates in mm 

 

Define … – press the button to measure the Nasion coordinates of the loaded scalp boundary 
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Perform the following steps: 

 

1. Click on the Estimate button to calculate the Nasion coordinates for the electrodes. The 

estimation is done from the already defined Cz and Fz positions in the montage file (see 

Section Create a Montage File). 

 

2. Click on the Define … button to measure the Nasion position of the MRI/CT image. A 

new figure opens with the scalp image. Try to find exactly the position of the Nasion and 

click with the left mouse button on it.  

 

 
 

3. Then press the right mouse button to close this window 
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4. A new window opens which shows the front side of the boundary. Select the Nasion 

position again and press the left button of the mouse. Close the window with a right 

mouse click. 

 

 
 

 

The Fit Electrodes window contains now the Nasion coordinates for both coordinate systems. 
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5. Press the Start ! button 

 

g.HReeg shows the fitted electrodes: 
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Visualization 
 
Chapter Visualization explains the tools for changing the appearance of the data maps, of the 

scalp and brain boundaries and of the electrodes. 

 

Visibility Settings 

Display Settings 

Axis Settings 
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Visibility Settings 

 

The Visualization menu allows to change the visibility of the data maps, brain, scalp and 

electrodes. 

 

Check or uncheck the corresponding item: 
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Display Settings 
 

The Display Settings window has the following entries: 

 

Set MAP parameters: 

 

Transparency of map [%] - enter the transparency value for the data map (0 is not 

transparent, 100 is totally transparent) 

 

Colormap - select a colormap for the data visualization 

 

Nr. of colors - define the number of colors used for the colormap 

 

Overall scaling - set the minimum and maximum equal for all maps 

 

Individual scaling - calculate the minimum and maximum for each colormap separately 

 

Confine to - enter manually the minimum and maximum values for all maps 

  

 
 

Show colorbar - check to show the colorbar 
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Show times - check to show the time information for each map 

 

Invert colormap - invert the minimum and maximum color of the map 

 

Min-0-Max autoscale - use an equal amount of colors for the values below and above 0 

 

 

Select ARRANGEMENT and TIME frame: 

 

Rows / cols - enter the number of rows and columns for the visualization of the maps 

 

Time steps [s] - enter the beginning and end time point in seconds for the visualization. The 

step size defines the number of maps which are shown. 

  

Samples - same as Time steps but the unit is samples 

 

 

Set SCALP parameters and Set BRAIN parameters: 

 

Color … - define the color of the boundary 

 

Transparency [%] - set the transparency of the boundary 

 

Apply above z= - set the boundary to the transparency value above this z-coordinate 

 

 

Set ELECTRODE parameters: 

 

Color … - define the color of the electrodes 

 

Size of electrode [mm] - set the size of the electrodes in mm 
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Axis Settings 

 

The Axis Settings window can be used to change the view of the axis and has the following 

entries: 

 

Define view – press the button to define the view angle 

 

Free rotation – rotate the head to define the view angle 

 

Define angles – enter the Azimuth and Elevation angle 

 

Show axis – check to show the coordinates 

 

Zoom factor [%] – enter the zoom factor to increase or decrease the visualization 
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Data Interpolation and Laplace Derivation 

 
Chapter Data Interpolation and Laplace Derivation explains how to interpolate the 

electrode positions and how to perform a spline surface Laplace derivation. 

 

Interpolate Data 

Calculate Laplace 
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Interpolate Data 

 

Refine Electrode Positions 
 

1. Load the data file SSLerd.mat in the Data menu with Load from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\erd 

 

2. With Load from the Scalp menu load the scalp boundary file subject1_scalp.bnd 

from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Boundary 

 

3. Add the electrode file electrode60.mat with Load from the Electrode menu from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Electrodes 

 

 

4. Open Display Setting under the Visualization menu and show second 4 and 6 of the data 

file, invert the colormap and select Confine to to set the optimal scaling (min: -120; 

max: 346). 

 

 

5. Open the Interpolate Data window from the Data menu 
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The window has the following entries: 

 

Select channels … – select the channels that should be used for the calculation. This function 

is useful if a channel contains artefacts and should be removed from processing. 

 

Read refined positions – load a boundary file (scalp or brain). The data map is interpolated 

onto this boundary. 

 

Refine electrode positions – check to interpolate the existing electrodes. The algorithm sets 

additional electrodes between existing electrodes and interpolates the colormap. 

 

Smoothing factor – set the smoothing factor to a value between 0 (no smoothing) and 100 

(maximum smoothing) 

 

 
 

6. Check the Refine electrode positions box and enter a Smoothing factor of 50 

 

7. Press Start ! to interpolate the electrode positions 

 

g.HReeg shows the interpolated data map. The status information field of g.HReeg shows that 

the data map has now 218 channels. Note that the electrode channels of a montage file must 

match the data channels exactly if the montage should be loaded. 
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8. Open the Display Settings window and set the Size of electrodes [mm] to 2 
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Read Refined Positions 
 

1. Load the data file SSLerd.mat with Load from the Data menu from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\erd 

 

2. From the Brain menu load the brain boundary file brain30mm.bnd with Load from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Boundary 

 

3. In the Electrode menu click Load to add the electrode file electrode60.mat from 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Electrodes 

 

 

Open Display Setting under the Visualization menu and show second 4 and 6 of the data file, 

invert the colormap and select Confine to to set the optimal scaling (min: -120; max: 346). 
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4. Open the Interpolate Data window from the Data menu 

 

 
 

5. Check the Read refine positions box and Browse for the file brain30mm.bnd under 

 
Documents\gtec\gBSanalyze\testdata\gHReeg\Boundary 

 

6. Enter a Smoothing factor of 50 

 

7. Press Start ! to perform the operation 

 

Note that small brain boundaries should be used for a fast calculation. The whole brain 

boundary would need a long computation time and a lot of memory. 

 

8. Open the Display Settings window. In the Set BRAIN parameters: section set 

Transperency [%]: to 100 and in the section Set ELECTRODE parameters: set the 

Size of electrodes [mm]: to 1 
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g.HReeg shows the data map interpolated onto the brain boundary.  
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Calculate Laplace 

 

The Spline Surface Laplacian derivation can be calculated from e.g. evoked potential (EP) 

signals generated with the Average function of g.BSanalyze. 

 

Perform the following steps: 

 

 

1. Open gMONcreator and load the file 44ch_sep.mat from 

 
Documents\gtec\gBSanalyze\testdata\montage 

 

The Montage Creator opens an extended 10/20 electrode system montage with 44 

electrodes. 

 

2. Click on Cz to inspect the coordinates. The coorindates are defined for a sphere with 1 

mm radius. 

 

3. Press the Fit to sphere button and enter a radius of 100 mm to convert the coordinates  

 

4. Save the montage file under 44ch_sep_100mm.mat under 

 
Documents\gtec\gBSanalyze\testdata\montage 

 

5. Open g.HReeg from the g.BSanalyze menu Run! with gHReeg and load the electrode 

montage file 44ch_sep_100mm.mat previously stored with Load from the Electrode 

menu. 

 

6. With Load from the Data menu add the EP data file EP.mat from 

 

Documents\gtec\gBSanalyze\testdata\gHReeg\average 

 

7. g.HReeg shows the electrodes and the EP maps. Open Display Settings and in the Select 

ARRANGEMENT and TIME frame set in Rows / Cols Nr. Rows: to 2 and Nr. Cols: 

to 6 and for Time steps [s]: set from: to 0.001, to: to 0.22, step is 0.019. 
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8. Open the window Calculate Laplacian from the Data menu: 

 

 
 

The window has the following entries: 

 

Select channels … - define the electrodes that should be used for the calculation 

Smoothing Factor – specify the smoothing value between 0 (no smoothing) and 100 

(maximum smoothing) 

 

9. Enter a Smoothing Factor of 10 and press the Start ! button. 

 

g.HReeg opens with the maps. Time point 0.172 (rounded to 0.18) is shown as example: 
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Help 

g.HReeg provides a printable documentation and a function help. 

The printable documentation is stored under  

C:\Program Files\gtec\gBSanalyze\Help 

 

as gHReeg.pdf. Use Acrobat Reader to view the documentation. 

 

 

To view the function help type 

 
help gBSfunctionname 

 

under the MATLAB command window.  

To view all functions that are available in batch mode type 

gBSfunctions 
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Product Page 

Please visit our homepage www.gtec.at for 

 Update announcements 

 Downloads 

 Troubleshooting 

 Additional demonstrations 

 

http://www.gtec.at/
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