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To the Reader

Welcome to g.tec’s world of medical and electrical engineering!

Discover the only professional biomedical signal processing platform under MATLAB and
Simulink. Your ingenuity finds the appropriate tools in the g.tec elements and systems.
Choose and combine flexibly the elements for biosignal amplification, signal processing and
stimulation to perform even real-time feedback.

Our team is prepared to find the better solution for your needs.
Take advantage of our experience!

Dr. Christoph Guger Dr. Guenter Edlinger

Researcher and Developer

Reduce development time for sophisticated real-time applications from month to hours.
Integrate g.tec's open platform seamlessly into your processing system.
g.tec's rapid prototyping environment encourages your creativity.

Scientist

Open new research fields with amazing feedback experiments.

Process your EEG/ECG/EMG/EQOG data with g.tec's biosignal analyzing tools.
Concentrate on your core problems when relying on g.tec's new software features like ICA,
AAR or online Hjorth's source derivation.

Study design and data analysis

You are planning an experimental study in the field of brain or life sciences? We can offer
consultation in experimental planning, hardware and software selection and can even do the
measurements for you. If you have already collected EEG/ECG/EMG/EOG, g.tec can analyze
the data starting from artifact control, do feature extraction and prepare the results ready for
publication.
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Preface

This section includes the following topics:

Required Products

Using This Guide - Suggestions for reading the handbook

Conventions - Text formats in the handbook
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Required Products

g®.CFMtoolbox uses:

g®.BSanalyze — the advanced biosignal analysis software package from g.tec
MATLAB - as basic matrix operation platform

Signal Processing Toolbox - to give access to standard signal analysis tools
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Using This Guide

Chapter “Running g.BSanalyze” shows how to start the Data Editor.

Chapter “Calculating CFM” shows how to calculate the cerebral function monitor signal from
EEG data.

Chapter “Classifying CFM” explains the classification of the CFM signals.

Chapter “Help” explains the usage of the on-line help, the printable documentation and the
function help.

Chapter “Batch-Mode” shows how to use the g.BSanalyze commands from the MATLAB
command line.

User Manual g.CFMtoolbox 5.16.02



Conventions

ltem Format
MATLAB code Courier

String variables Courier italics
Menu items Boldface

User Manual g.CFMtoolbox

Example

to start simulink, type
simulink

set (P_C, '"PropertyName', ...

Select Save from the File menu.

5.16.02



Hardware and Software Requirements

For Hardware and Software Requirements see the g.BSanalyze manual.
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Running g.BSanalyze
After starting MATLAB and setting the correct path, type:
gbsanalyze

in the MATLAB command line

4\ Command Window — O >

fx »> ghsanalyze

g.BSanalyze starts with a blank data window.
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Calculating CFM

The first step is to load EEG data into g.BSanalyze. Then the CFM method is used to
calculate the cerebral function monitor (CFM) signal from the EEG data.

The CFM window has the following control elements:
Specify data interval:
Start interval at - enter the starting time point for the analysis
End at - enter the end time point of the analysis
Select channels - allows specifying the EEG channel that should be used for the analysis
Specify the parameters:
Method - can be Traditional or Hos. The CFM algorithm Traditional
asymmetrically bandpass filters the data. Then the root-mean square function is
calculated. This results in the CFM estimation of the EEG data. The ros algorithm
uses higher order statistics for the CFM estimation.

FilterBand — specify the Lowest and Highest frequency for the bandpass filtering (if
the Traditional method is used)

Classify CFM Pattern — check the box to automatically classify the CFM patterns

Percentile — specify the percentile in percentage to calculate the lower and upper limit
of the CFM signal

Epoch — define the epoch length for the automatic classification
Result procedure:
Show with gCFMViewer — check to visualize the CFM signal
Save result — check to store the calculated CFM signal
Perform the following steps:

1. Click on Load Data under the File menu of g.BSanalyze and select the file cfm1.mat
from

Documents\gtec\gBSanalyze\testdata\CFM

2. Select Open to load the EEG data file of a baby. The EEG data is a bipolar recording
between C3 and C4 according to the international 10/20 system. The ground electrode was
fixed on the forehead. The Data Editor shows the first 10 seconds of the recording.
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The data is shown with a sensitivity of £0.5mV.
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3. Open the CFM window from the Analyze menu

#.| CFM - Cerebral Function Monitor — hod

Calculate the cerebral function monitor signal for a specific interval. Check Classify CFM Pattern for
automatic segmentation of the CFM.

— Specify DATA INTERWVAL:

Start interval at: | §51042e-05 | [min] End at: 100 [min]
1 [zamples] 1.536e+06 [samples]
— Select CHANNELS:
Select channels ...
— Specify the PARAMETERS:
Method: Traditional o
Fitter Band:
Lowest frequency: 2 [Hz] Highest frequency: 15 [HZ]
[ ] claz=ify CFM Pattern
Percentile: 5 Epoch Duration: 10 [min] Pattern definition ...
Result procedure: v i i
P L Automatic treemaker i=. | anabled o
|:| Save results Filename: enter filename
Help Cancel | Start !

4. To calculate the CFM signal from all 100 minutes with the Traditional method and to
perform a bandpass filtering between 2 and 15 Hz press Start
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5. The g.CFMViewer opens with the CFM signal of the EEG channel

4] g.CFMViewer

File Calculate Definition
100
50
25 |r

10

CFM [uV]

Help

| | | | |

| I I I |

| |

80 %0 100 110 120
Time [min]

130 140 150 160 170

| J
190 200 210 220 230 240

The y-axis shows the CFM signal in pV and the x-axis the time in minutes. The signal is
mainly between 2 uV and 50 uV. The scroll buttons can be used to navigate through longer

data-sets.

6. Click on Print Preview in the g.CFMViewer menu to open the following window and
click on the Print button for a hardcopy.

4| Print Preview

StyleSheet | modified

Layout Lines/Text Color Advanced

Placement

(® Auto (Actual Size, Centered}

() Use manual size and position

Left:
Top:
Width:
Height:

Paper
Format: | Ad
Width:
Height:

Units:

(®) Inches

(O) Centimeters
() Points

Orientation

() Portrait
®) Landscape

() Rotated
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Save As...

116015

82715

Zoom | Qverview

1 2

e

- m} X

Refresh Help Close

8 g 10 " -

5.16.02

13



Classifying CFM

1. Load the data-set into g.BSanalyze as described in the previous section and open the CFM
window

2. Check Classify CFM Pattern to enable the corresponding editor boxes
3. Epoch Duration is set to 10 minutes. This divides the CFM signal into segments of 10
minutes and of each segment the upper and the lower percentile is calculated. Percentile

is set to 5 %. Therefore the upper 5 % percentile and the lower 5 % percentile of each 10
minutes segment are calculated.

#.| CFM - Cerebral Function Monitor — ot

Calculate the cerebral function monitor gignal for a specific interval. Check Clazsify CFM Pattern for
automatic =egmentation of the CFM.

— Specify DATA INTERVAL:

Start interval at: 5.51042e-05 [min] End at: 100 [min]

1 [zamples] 1.536e+06 [samples]

— Select CHAMMELS:

Select channels ...
— Specify the PARAMETERS:
Method: Traditional =
Fiter Band:
Lowest frequency: 2 [Hz] Highest frequency: 15 [Hz]

Clazzify CFM Pattern

Percentile: g Epoch Duration: 10 [min] Pattern definition ...

Result procedure: | i Vi
: Show with aCFRIViewer Automatic treemaker i=. | anabled e

Save results: Filename: . lyzeltestdata\CFM\cfmicfmpattern.mat| ...

Help Cancel | Start !
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4. Open the Pattern definition ...

4. Select Pattern

. Define patterns for the CFM classification.

window to edit the borders for the automatic classification

~ SETTINGS:
Name of Pattern:

CVP

DLVP

DHVP

150

BSP

BURST

From GT{=)
From |GT(=) ~
From | GE (==)
From GT(=)
From GT(=)
From GT(=)

£

w

w
From ~
From bl
From bl
w

From

Lower Level [pV]
0 To [GT(=)
LT(=}
LE (==}
LT(=}
LT(=}
GT(=)

0
3 To
0
0

70 70

C(E[€[€]|€|€|€|€|€ |«

=]
5
5
1%
@2
=3
H

Upper Level [uV]

From |GE (=<} ~| 10 | To |LE (==} 70 .
From |GE (»=) ~| 15 To |LE (<=) 70
From GE (>=) ~| 10 | T0 |LE (<=) 70
From | 7<) ~| 10 | To |LT(<) 10 [ |
From GE (=) ~| 10 | To |LT(<) 1 B

From |GT(=) =~ | 70 70

GT(=)
From

From

Cle (|| [C e |[€]|e |«

From

OO0 R E R R E

(€€«

From

Help |  Cancel | oKkt |

The window allows to specify 10 patterns with a lower and upper level. Enter a name for each
pattern and the threshold values of the lower and upper percentiles. Then select a color for the
pattern and check the box if this pattern should be used for the analysis. 6 standard patterns
are already pre-defined. Press OK ! to confirm the pattern settings.

5. Check the Save results box and enter the filename cfmpattern.mat to store the
calculated CFM data to harddisk
6. Press Start to perform the calculation
7. g.CFMViewer opens automatically with the results
\ I'H'lm I
“'In M
| | | | | I | | | | | | J
111'?;“[,";]20 130 140 150 160 170 180 190 200 zmﬂé}jjljﬂj
o % 1D;VP ;:VF’ :32 si ;B'URST :ndeﬁneﬂ ':;;a\
%] 10 10 80 0 1] 100
8. Now additionally to the CFM signal the lower and upper percentiles are shown with blue

lines for each 10 min segment. These percentiles were used for the automatic
classification of the CFM data. The results are shown with the coloured boxes under the
CFM signal. In this case the first 50 minutes correspond to puvp, the next segment to

DLVP,...

The CFM statistic is presented under the plot. Ten minutes correspond to the class cve, 10
minutes to DLVP and 80 minutes to DHVP. No CFM traces are available which
correspond to 150, BSP OF BURST.
If no pattern can be assigned according to the pattern definition an undefined Iis
assigned. The last line shows the distribution in percentage.
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9. To manually correct the automatic classification right click on the patterns and assign a
different pattern name. The color of the segment changes.

4. g.CFMViewer

File Calculate Definition Help

100

SD

i
j” A“ | Mlh.m. W Iﬂ

CFM [uV]

i 'w lu, 1,‘ |[ ,I T,,.
M 1“ !

0 __ I
0 10 20 30 40 50 60 70 80 VP oo
DLVP
DHVE [,
150
cvp DLVP DHVP 150 BSP gsp R8T
| | I
[min] 10 10 80 0 0 BURST
uDpP
[%] 10 10 80 0 0 U

10. After performing the corrections of all segments select Calculate Statistics to update the
pattern distribution

4| g.CFMViewer
File | Calculate Definition Help

Statistics Q
Pattern -

e 1

11. Select Pattern under the Definition menu to change the pattern definition and then start
again the classification with Pattern from menu Calculate
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gCFMViewer

The g.CFMViewer is used to view the CFM data of one channel.

To start the g.CFMViewer go to the Data Editor and select gcrmviewer under the Run menu

Video | Run! Help

Lser

gMOMcreator

gResult2D

gHReeg

gCFMViewer Q

or type

gCFMViewer

into the MATLAB command window.

To view already stored CFM data use the Load Data function from the File menu.

Perform the following steps to load the data from the MATLAB command line:

Type

load cfmpattern.mat

into the command line.

This loads the CFM object crm_ s into the MATLAB workspace.

Use

gCFMViewer (CFM S)

to visualize the data with g.CFMViewer.

To extract the CFM data from the object use

y=CFM_S.Out;
plot(y(:,1));
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Help

g.BSanalyze and the g.CFMtoolbox provide a printable documentation and a function help.

The printable documentation is stored under

C:\Program Files\gtec\gBSanalyze\Help

as gCFMtoolbox.pdf. Use Acrobat Reader to view the documentation.

To view the function help type

help gBSfunctionname

under the MATLAB command window.

To view all functions that are available in batch mode type

gBSfunctions

User Manual g.CFMtoolbox 5.16.02
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Batch Mode

The easiest way to create a batch for data processing is to perform the analysis under the Data
Editor using the graphical user interfaces. Make sure that the Show diary checkbox is enabled
in Appearance Settings under the Options menu.

— COMNFIEMATION: ——

[ ] A=k for confirmation
before EXIT

Azk for confirmation
before CUT

Show diary

This forces g.BSanalyze to report all calculations in the MATLAB command window. After
finishing the analysis open a New Script and copy and paste all commands into the file.

A\ MATLAB R2015a

HOME

|i}!' Eﬂj ™ [E S & E Cizy New Variable | Analyze Co

Open Variable « > Run and Tin
New |MNew | Open glﬂnmpare Import Save 5 é‘]}
Script | v+ |« Data Workspace [ Clear Workspace ~ [/ Clear Comm
. VARIABLE CODE
e = Script % Ctri=N
= Iriria » Documents » gtec » gBSanalyze » testdata »
Curren| |fi| Function ®
Yy
k&ﬂ Example
%(Load Data
Eﬂt P C=data:;
=) Class — o
‘|J File='C:\Users\Irimia‘ Documen
: t o = i =
> t E System Object 3 P C=lpad(P _C,File):
o
‘* Figure £Valid dongle
Graphical User Interface ECFM
Interval = [1 1536000];
|A| Command Shortcut ChannelExclude = []:
Method = ['Traditional']:
T FilterBand = [2 15];
P2 simulink Model Percentile = []:
Epoch = []:
|_;'_| simulink Project > Pattern = [];
FileName = ["']:

ProgressBarFlag=0;
[CFH] = gBScfm(P C, Interwval,
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@ ChUsershIrimia\Docurnentst gtec gBSanalyze' testdata CFMymybatch.m — O x

EDMTOR PUBLISH WIEWW

E:—_'I:I E ﬁ EHMHE < S D % L:;:lﬂunSediun &?

=| Compare GoTo =
HewﬂpmSam'l:l e ED'Tmmmﬂsmnmnw@m Run and

- - - Eapﬁi - 4 Find - ~  Advance Time

FILE | MAVIGATE |‘IIr |BHEA}(P0|NT3| RUM h

1 iLoad Data

2 - F C=data;

2= File="C:“\Userz'\Irimia‘Documentsi\gtechgBSanalyvze\testdata\CFM\cfml.mat" ;

4 - P C=load(F _C,File};

o9

[ FValid dongle

7

g :CFM

9 - Interval = [1 1536000]:;

10 = ChannelExclude = []:

11 = Method = ['Traditiomal']:

12 = FilterBand = [2 15]:

13 — Percentile = []:

14 — Epoch = []:

15 = Pattern = []: —_—

16 — FileMame = ["'];

17 — ProgressBarFlag=0;

18 — [CFM] = gBScfm(F_C, Interval, Method, FilterBand,...

13 Percentile, Epoch, Pjpttern, ChannelExclude, FileName, ProgressBarFlag), —

I« >

2 usages of "Pattern” found | script | Ln 19 Col 21

Save the batch in your own directory as mybatch.m and start the batch under the MATLAB
command window with

mybatch

In order to investigate further data-sets just replace the input data file by the new data file to
perform the same analysis.
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Product Page

Please visit our homepage www.gtec.at for
o Update announcements

e Downloads

Troubleshooting
Additional demonstrations
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http://www.gtec.at/

g.tec medical engineering GmbH tel. +43 7251 22240
Sierningstrasse 14 fax. +43 72512224039
4521 Schiedlberg web: www.gtec.at
Austria e-mail: office@gtec.at
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